summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Brigante <github@bfred.it>2018-04-19 22:30:36 +0700
committerFederico Brigante <github@bfred.it>2018-04-19 22:30:36 +0700
commitd08a0ac6888ec06181a23de9a43145fc1a548f37 (patch)
treea0d91ebb62db93d9e70ea6cf4057f4ef9f3fa051
parent6fb52d223941e27f691eb918200eebba102ada43 (diff)
downloadasync-d08a0ac6888ec06181a23de9a43145fc1a548f37.tar.gz
Drop lodash transform in makefile
-rw-r--r--Makefile3
1 files changed, 0 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 8880e02..d581ae2 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,6 @@ PACKAGE = asyncjs
REQUIRE_NAME = async
UGLIFY = uglifyjs
XYZ = support/xyz.sh --repo git@github.com:caolan/async.git
-COPY_ES = sed -E "s/(import.+)lodash/\1lodash-es/g"
BUILDDIR = build
BUILD_ES = build-es
@@ -95,12 +94,10 @@ build-es: $(ES_MODULES)
$(BUILD_ES)/%.js: lib/%.js
mkdir -p "$(@D)"
- $(COPY_ES) $< > $@
define COPY_ES_ALIAS
$A: $(shell node $(SCRIPTS)/get-alias.js $A)
mkdir -p "$$(@D)"
- $(COPY_ES) $$< > $$@
endef
$(foreach A,$(ALIAS_ES),$(eval $(COPY_ES_ALIAS)))