summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-06-30 16:27:48 -0700
committerAlexander Early <alexander.early@gmail.com>2016-06-30 16:27:48 -0700
commitb83ce9494533141505eebff25ef57d66b72ba5ac (patch)
tree694b5b584901a84406992bcb9efb3e39f2aa677f
parent98d3736f60d5bf0d2c5f83a130a8275fc46bb53d (diff)
downloadasync-b83ce9494533141505eebff25ef57d66b72ba5ac.tar.gz
add docs publishing script. Related to #1202
-rw-r--r--Makefile6
-rw-r--r--package.json6
2 files changed, 11 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 701f27d..e180aa9 100644
--- a/Makefile
+++ b/Makefile
@@ -117,3 +117,9 @@ release-major release-minor release-patch release-prerelease: all
$(MAKE) build-es-config
cd build/ && npm publish
cd build-es/ && npm publish
+ $(MAKE) doc
+
+.PHONY: doc
+doc:
+ npm run-script jsdoc
+ gh-pages-deploy
diff --git a/package.json b/package.json
index 250e062..16e9f7e 100644
--- a/package.json
+++ b/package.json
@@ -37,6 +37,7 @@
"esdoc": "^0.4.7",
"eslint": "^2.11.1",
"fs-extra": "^0.26.7",
+ "gh-pages-deploy": "^0.4.2",
"jsdoc": "^3.4.0",
"karma": "^0.13.2",
"karma-browserify": "^4.2.1",
@@ -70,5 +71,8 @@
"mocha-test": "npm run mocha-node-test && npm run mocha-browser-test",
"test": "npm run-script lint && npm run mocha-node-test"
},
- "license": "MIT"
+ "license": "MIT",
+ "gh-pages-deploy": {
+ "staticpath": "docs"
+ }
}