summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2017-04-16 21:33:20 -0700
committerAlexander Early <alexander.early@gmail.com>2017-04-16 21:33:20 -0700
commiteb21089d62a378f7b308bca5fc545e2c1eb12f78 (patch)
treee9588c29660e5eca55c4d982909c30a708f33d6e
parent8fba4e5398f7c3cec8ab5f53986f80e8fb5c2dbf (diff)
downloadasync-eb21089d62a378f7b308bca5fc545e2c1eb12f78.tar.gz
rename compile->compile-module.js
-rw-r--r--Makefile2
-rwxr-xr-xsupport/build/compile-module.js (renamed from support/build/compile)1
2 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8e5ef04..4cfc9d1 100644
--- a/Makefile
+++ b/Makefile
@@ -46,7 +46,7 @@ build-modules: $(CJS_MODULES)
$(BUILDDIR)/%.js: lib/%.js
mkdir -p "$(@D)"
- node $(SCRIPTS)/build/compile --file $< --output $@
+ node $(SCRIPTS)/build/compile-module.js --file $< --output $@
$(UMD_BUNDLE): $(ES_MODULES) package.json
mkdir -p "$(@D)"
diff --git a/support/build/compile b/support/build/compile-module.js
index 0b4fdd3..38a4d38 100755
--- a/support/build/compile
+++ b/support/build/compile-module.js
@@ -19,6 +19,7 @@ function compileModule(options, callback) {
transformFile(file, {
babelrc: false,
+ ast: false,
plugins
}, (err, content) => {
if (err) return callback(err);