summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2019-05-19 19:23:24 -0700
committerAlexander Early <alexander.early@gmail.com>2019-05-19 19:25:58 -0700
commit3fa33dd70c786d98dc203ae8a0d4d434d418dbd6 (patch)
tree291cb967ac30819305e382746a843a2a87120448
parentaa1c7988c5f9d4368cbcb0a1547c2a36380b889c (diff)
downloadasync-3fa33dd70c786d98dc203ae8a0d4d434d418dbd6.tar.gz
move async.mjs to dist
-rw-r--r--Makefile2
-rw-r--r--support/build/aggregate-module.js2
-rwxr-xr-xsupport/sync-cjs-package.js2
3 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 22d19cc..f14f70e 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ LINT_FILES := lib/ test/ $(shell find perf/ -maxdepth 2 -type f) $(shell find su
UMD_BUNDLE := $(BUILDDIR)/dist/async.js
UMD_BUNDLE_MIN := $(BUILDDIR)/dist/async.min.js
-MJS_BUNDLE := $(BUILDDIR)/async.mjs
+MJS_BUNDLE := $(BUILDDIR)/dist/async.mjs
# UMD_BUNDLE_MAP := $(BUILDDIR)/dist/async.min.map
ALIAS_ES := $(addprefix build-es/, $(addsuffix .js, $(shell cat $(SCRIPTS)/aliases.txt | cut -d ' ' -f1)))
ALIAS_CJS := $(patsubst build-es/%, build/%, $(ALIAS_ES))
diff --git a/support/build/aggregate-module.js b/support/build/aggregate-module.js
index 804f591..fde7e78 100644
--- a/support/build/aggregate-module.js
+++ b/support/build/aggregate-module.js
@@ -9,7 +9,7 @@ rollup({
return bundle.write({
format: 'esm',
name: 'async',
- file: 'build/async.mjs'
+ file: 'build/dist/async.mjs'
});
})
.catch((err) => { throw err; });
diff --git a/support/sync-cjs-package.js b/support/sync-cjs-package.js
index 70991a2..dff4472 100755
--- a/support/sync-cjs-package.js
+++ b/support/sync-cjs-package.js
@@ -2,6 +2,6 @@
var fs = require('fs');
var json = JSON.parse(fs.readFileSync(__dirname + "/../package.json"), "utf8");
-json.module = 'async.mjs'
+json.module = 'dist/async.mjs'
process.stdout.write(JSON.stringify(json, null, 2));