summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-07-07 17:32:05 -0700
committerAlexander Early <alexander.early@gmail.com>2016-07-07 17:32:34 -0700
commit8685199248c4a7725722aa52d91c10b492177331 (patch)
treeb1500c909019a28569f9f635ee785b4949a45c70
parentf9c3f06b5e9343fadc574bb3b762f6a7c46ca452 (diff)
downloadasync-8685199248c4a7725722aa52d91c10b492177331.tar.gz
add doc generation to makefile
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 439a9da..c222803 100644
--- a/Makefile
+++ b/Makefile
@@ -117,10 +117,14 @@ release-major release-minor release-patch release-prerelease: all
$(MAKE) build-es-config
cd build/ && npm publish
cd build-es/ && npm publish
- $(MAKE) doc
+ $(MAKE) publish-doc
-.PHONY: doc
+.PHONY: doc publish-doc
doc:
+ jsdoc -c ./support/jsdoc/jsdoc.json
+ node support/jsdoc/jsdoc-fix-html.js
+
+publish-doc: doc
git diff-files --quiet # fail if unstanged changes
git diff-index --quiet HEAD # fail if uncommited changes
npm run-script jsdoc