summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn-David Dalton <john.david.dalton@gmail.com>2016-05-27 12:37:07 -0700
committerJohn-David Dalton <john.david.dalton@gmail.com>2016-05-31 15:24:40 -0700
commiteaa5318c9b523eaf666e1495d27af2a937288a79 (patch)
tree52640e7191c4e6ad950582f25a252f798792d4ec
parentdf34c15003489a3bed056278bf7d14394e5f85cc (diff)
downloadasync-eaa5318c9b523eaf666e1495d27af2a937288a79.tar.gz
Reduce package manager scaffolding.
-rw-r--r--Makefile6
-rw-r--r--bower.json70
-rw-r--r--component.json17
-rw-r--r--package.json28
-rwxr-xr-xsupport/sync-package-managers.js55
-rwxr-xr-xsupport/xyz.sh3
6 files changed, 13 insertions, 166 deletions
diff --git a/Makefile b/Makefile
index 3bc6e9f..f9c883e 100644
--- a/Makefile
+++ b/Makefile
@@ -85,12 +85,6 @@ build-config: $(BUILDDIR)/package.json $(BUILDDIR)/component.json $(BUILDDIR)/bo
build-es-config: $(BUILD_ES)/package.json $(BUILD_ES)/README.md $(BUILD_ES)/LICENSE $(BUILD_ES)/CHANGELOG.md
-bower.json: package.json
- support/sync-package-managers.js
-
-component.json: package.json
- support/sync-package-managers.js
-
$(BUILDDIR)/package.json: package.json
mkdir -p "$(@D)"
support/sync-cjs-package.js > $@
diff --git a/bower.json b/bower.json
index d6cf8ec..7dbeb14 100644
--- a/bower.json
+++ b/bower.json
@@ -1,65 +1,17 @@
{
"name": "async",
- "description": "Higher-order functions and common patterns for asynchronous code",
"main": "dist/async.js",
- "keywords": [
- "async",
- "callback",
- "module",
- "utility"
- ],
- "license": "MIT",
- "repository": {
- "type": "git",
- "url": "https://github.com/caolan/async.git"
- },
- "devDependencies": {
- "babel-cli": "^6.3.17",
- "babel-core": "^6.3.26",
- "babel-plugin-add-module-exports": "~0.1.2",
- "babel-plugin-transform-es2015-modules-commonjs": "^6.3.16",
- "babel-preset-es2015": "^6.3.13",
- "babelify": "^7.2.0",
- "benchmark": "bestiejs/benchmark.js",
- "bluebird": "^2.9.32",
- "chai": "^3.1.0",
- "coveralls": "^2.11.2",
- "es6-promise": "^2.3.0",
- "fs-extra": "^0.26.7",
- "jscs": "^1.13.1",
- "jscs-jsdoc": "^1.3.2",
- "jshint": "~2.8.0",
- "karma": "^0.13.2",
- "karma-browserify": "^4.2.1",
- "karma-firefox-launcher": "^0.1.6",
- "karma-mocha": "^0.2.0",
- "karma-mocha-reporter": "^1.0.2",
- "mocha": "^2.2.5",
- "native-promise-only": "^0.8.0-a",
- "nyc": "^2.1.0",
- "recursive-readdir": "^1.3.0",
- "rimraf": "^2.5.0",
- "rollup": "^0.25.0",
- "rollup-plugin-node-resolve": "^1.5.0",
- "rollup-plugin-npm": "~1.3.0",
- "rsvp": "^3.0.18",
- "semver": "^4.3.6",
- "uglify-js": "~2.4.0",
- "yargs": "~3.9.1"
- },
- "moduleType": [
- "amd",
- "globals",
- "node"
- ],
"ignore": [
- "**/.*",
- "node_modules",
"bower_components",
- "test",
- "tests"
- ],
- "authors": [
- "Caolan McMahon"
+ "lib",
+ "mocha_test",
+ "node_modules",
+ "perf",
+ "support",
+ "**/.*",
+ "*.config.js",
+ "*.json",
+ "index.js",
+ "Makefile"
]
-} \ No newline at end of file
+}
diff --git a/component.json b/component.json
deleted file mode 100644
index c9ecb4c..0000000
--- a/component.json
+++ /dev/null
@@ -1,17 +0,0 @@
-{
- "name": "async",
- "description": "Higher-order functions and common patterns for asynchronous code",
- "version": "2.0.0-rc.5",
- "keywords": [
- "async",
- "callback",
- "module",
- "utility"
- ],
- "license": "MIT",
- "main": "dist/async.js",
- "repository": "caolan/async",
- "scripts": [
- "dist/async.js"
- ]
-} \ No newline at end of file
diff --git a/package.json b/package.json
index 80396e0..b0e07b4 100644
--- a/package.json
+++ b/package.json
@@ -64,29 +64,5 @@
"mocha-test": "npm run mocha-node-test && npm run mocha-browser-test",
"test": "npm run-script lint && npm run mocha-node-test"
},
- "license": "MIT",
- "jam": {
- "main": "dist/async.js",
- "include": [
- "dist/async.js",
- "README.md",
- "LICENSE"
- ],
- "categories": [
- "Utilities"
- ]
- },
- "spm": {
- "main": "dist/async.js"
- },
- "volo": {
- "main": "dist/async.js",
- "ignore": [
- "**/.*",
- "node_modules",
- "bower_components",
- "test",
- "tests"
- ]
- }
-} \ No newline at end of file
+ "license": "MIT"
+}
diff --git a/support/sync-package-managers.js b/support/sync-package-managers.js
deleted file mode 100755
index d01d17c..0000000
--- a/support/sync-package-managers.js
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/usr/bin/env node
-
-// This should probably be its own module but complaints about bower/etc.
-// support keep coming up and I'd rather just enable the workflow here for now
-// and figure out where this should live later. -- @beaugunderson
-
-var fs = require('fs');
-var _ = require('lodash');
-
-var packageJson = require('../package.json');
-
-var IGNORES = ['**/.*', 'node_modules', 'bower_components', 'test', 'tests'];
-var INCLUDES = ['dist/async.js', 'README.md', 'LICENSE'];
-var REPOSITORY_NAME = 'caolan/async';
-
-packageJson.jam = {
- main: packageJson.main,
- include: INCLUDES,
- categories: ['Utilities']
-};
-
-packageJson.spm = {
- main: packageJson.main
-};
-
-packageJson.volo = {
- main: packageJson.main,
- ignore: IGNORES
-};
-
-var bowerSpecific = {
- moduleType: ['amd', 'globals', 'node'],
- ignore: IGNORES,
- authors: [packageJson.author]
-};
-
-var bowerInclude = ['name', 'description', 'main', 'keywords',
- 'license', 'homepage', 'repository', 'devDependencies'
-];
-
-var componentSpecific = {
- repository: REPOSITORY_NAME,
- scripts: [packageJson.main]
-};
-
-var componentInclude = ['name', 'description', 'version', 'keywords',
- 'license', 'main'
-];
-
-var bowerJson = _.merge({}, _.pick(packageJson, bowerInclude), bowerSpecific);
-var componentJson = _.merge({}, _.pick(packageJson, componentInclude), componentSpecific);
-
-fs.writeFileSync('./bower.json', JSON.stringify(bowerJson, null, 2));
-fs.writeFileSync('./component.json', JSON.stringify(componentJson, null, 2));
-fs.writeFileSync('./package.json', JSON.stringify(packageJson, null, 2));
diff --git a/support/xyz.sh b/support/xyz.sh
index cb92577..cff4dd2 100755
--- a/support/xyz.sh
+++ b/support/xyz.sh
@@ -13,8 +13,6 @@ This involves updating the version number in package.json, committing this
change (along with any staged changes), tagging the commit, pushing to the
remote git repository, and finally publishing to the public npm registry.
-If present, component.json is updated along with package.json.
-
Options:
-b --branch <name>
@@ -160,7 +158,6 @@ inc() {
inc package.json
-run "$dir/sync-package-managers.js"
run "git add --force *.json"
run "git commit --message '$message'"