summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Early <alexander.early@gmail.com>2016-05-31 13:39:52 -0700
committerAlex Early <alexander.early@gmail.com>2016-05-31 13:39:52 -0700
commitf97c1541632812216ed8dfe1306e5cba689cc17d (patch)
tree9b47cded9005b438e5eb2e2c5f73fcf4efb9eae7
parent4931114cd6844b3d7c5e7e9d4e6d3b54d0ad95ab (diff)
parent02381795698f522d66138d3865b8cc75772d9104 (diff)
downloadasync-f97c1541632812216ed8dfe1306e5cba689cc17d.tar.gz
Merge pull request #1171 from jnordberg/makefile-osx
Fix Makefile build on OS X
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c1ccdb9..3bc6e9f 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@
# created here are checked in so people on all platforms can run npm scripts.
# This build should be run once per release.
+SHELL=/bin/bash
export PATH := ./node_modules/.bin/:$(PATH):./bin/
PACKAGE = asyncjs
@@ -75,7 +76,7 @@ build-es: $(ES_MODULES)
$(BUILD_ES)/%.js: lib/%.js
mkdir -p "$(@D)"
- sed -r "s/(import.+)lodash/\1lodash-es/g" $< > $@
+ sed -E "s/(import.+)lodash/\1lodash-es/g" $< > $@
test-build:
mocha support/build.test.js