summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2017-04-16 21:03:48 -0700
committerAlexander Early <alexander.early@gmail.com>2017-04-16 21:03:48 -0700
commit80361aaccbca9cd2af30b76e5e93b58d25faa65b (patch)
tree1532f3f95b8c54aed38c314531fc122622faf298
parentacce4d9c0d2cfc2908730c6fd4d864005d63a0f0 (diff)
downloadasync-80361aaccbca9cd2af30b76e5e93b58d25faa65b.tar.gz
remove unused CJS index.js file
-rw-r--r--Makefile6
-rw-r--r--support/build/aggregate-cjs.js17
-rw-r--r--support/build/modules-cjs.js4
3 files changed, 4 insertions, 23 deletions
diff --git a/Makefile b/Makefile
index 6b2d37e..904a373 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,6 @@ LINT_FILES = lib/ mocha_test/ $(shell find perf/ -maxdepth 2 -type f) $(shell fi
UMD_BUNDLE = $(BUILDDIR)/dist/async.js
UMD_BUNDLE_MIN = $(BUILDDIR)/dist/async.min.js
-CJS_BUNDLE = $(BUILDDIR)/index.js
ES_MODULES = $(patsubst lib/%.js, build-es/%.js, $(JS_SRC))
@@ -40,7 +39,7 @@ lint:
eslint $(LINT_FILES)
# Compile the ES6 modules to singular bundles, and individual bundles
-build-bundle: build-modules $(UMD_BUNDLE) $(CJS_BUNDLE)
+build-bundle: build-modules $(UMD_BUNDLE)
build-modules:
node $(SCRIPTS)/build/modules-cjs.js
@@ -49,9 +48,6 @@ $(UMD_BUNDLE): $(ES_MODULES) package.json
mkdir -p "$(@D)"
node $(SCRIPTS)/build/aggregate-bundle.js
-$(CJS_BUNDLE): $(JS_SRC) package.json
- node $(SCRIPTS)/build/aggregate-cjs.js
-
# Create the minified UMD versions and copy them to dist/ for bower
build-dist: $(DIST) $(UMD_BUNDLE) $(UMD_BUNDLE_MIN) $(DIST)/async.js $(DIST)/async.min.js
diff --git a/support/build/aggregate-cjs.js b/support/build/aggregate-cjs.js
deleted file mode 100644
index a5c60b8..0000000
--- a/support/build/aggregate-cjs.js
+++ /dev/null
@@ -1,17 +0,0 @@
-const aggregateBuild = require('./aggregate-build');
-const compileModules = require('./compile-modules');
-const {series} = require('async');
-const outpath = 'build/modules-for-cjs';
-
-series([
- compileModules.bind(null, {
- es6: true,
- outpath,
- lodashRename: false
- }),
- aggregateBuild.bind(null, {
- entriesPath: outpath,
- outfile: 'build/index.js',
- format: 'cjs',
- })
-], err => { if (err); throw err; });
diff --git a/support/build/modules-cjs.js b/support/build/modules-cjs.js
index e131a42..aabd469 100644
--- a/support/build/modules-cjs.js
+++ b/support/build/modules-cjs.js
@@ -1,5 +1,7 @@
const compileModules = require('./compile-modules');
compileModules({
- es6: false
+ es6: false,
+ path: 'lib/',
+ outpath: 'build'
}, err => { if (err) throw err; });