summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-05-05 16:28:27 -0700
committerAlexander Early <alexander.early@gmail.com>2016-05-05 16:28:27 -0700
commit3ed8168c69c9e63e2ec7ded53abcfd760ca8812d (patch)
tree71fba13cddef10ebf62a472f55e5fbad8108ded6
parent21f917ecd0485d1ffe28ae70067124e0afaf838b (diff)
downloadasync-3ed8168c69c9e63e2ec7ded53abcfd760ca8812d.tar.gz
use npm publish rather than pack
-rw-r--r--Makefile4
-rwxr-xr-xsupport/xyz.sh3
2 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 6e09554..c3bf33e 100644
--- a/Makefile
+++ b/Makefile
@@ -120,5 +120,5 @@ release-major release-minor release-patch release-prerelease: all
# build again to propagate the version
$(MAKE) build-config
$(MAKE) build-es-config
- cd build/ && npm pack
- cd build-es/ && npm pack
+ cd build/ && npm publish
+ cd build-es/ && npm publish
diff --git a/support/xyz.sh b/support/xyz.sh
index e178eee..cb92577 100755
--- a/support/xyz.sh
+++ b/support/xyz.sh
@@ -167,5 +167,4 @@ run "git commit --message '$message'"
run "git tag --annotate '$tag' --message '$message'"
run "git push '$repo' 'refs/heads/$branch' 'refs/tags/$tag'"
-#cd build/
-#run "npm pack"
+# npm publish is managed by the Makefile