summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorezubarev <zubarev.eugene@gmail.com>2016-05-06 14:06:48 +0600
committerezubarev <zubarev.eugene@gmail.com>2016-05-06 14:06:48 +0600
commitbded75f221caf8e84fcc8359d4def51e4a04f5d5 (patch)
tree664d8bcad8072b55f702e680a024de77cf841fc5
parent667affc619e8b688c0be87c7da72667fea1c8781 (diff)
downloadasync-bded75f221caf8e84fcc8359d4def51e4a04f5d5.tar.gz
Get rid of nodeunit
-rw-r--r--Makefile2
-rw-r--r--bower.json3
-rw-r--r--package.json8
-rwxr-xr-xtest/test-async.js6
-rw-r--r--test/test.html24
5 files changed, 5 insertions, 38 deletions
diff --git a/Makefile b/Makefile
index c3bf33e..5104ce8 100644
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ DIST = dist
SRC = lib/index.js
SCRIPTS = ./support
JS_SRC = $(shell find lib/ -type f -name '*.js')
-LINT_FILES = lib/ test/ mocha_test/ $(shell find perf/ -maxdepth 2 -type f) support/ karma.conf.js
+LINT_FILES = lib/ mocha_test/ $(shell find perf/ -maxdepth 2 -type f) support/ karma.conf.js
UMD_BUNDLE = $(BUILDDIR)/dist/async.js
UMD_BUNDLE_MIN = $(BUILDDIR)/dist/async.min.js
diff --git a/bower.json b/bower.json
index 5f0bade..dfdb8bb 100644
--- a/bower.json
+++ b/bower.json
@@ -36,7 +36,6 @@
"karma-mocha-reporter": "^1.0.2",
"mocha": "^2.2.5",
"native-promise-only": "^0.8.0-a",
- "nodeunit": ">0.0.0",
"nyc": "^2.1.0",
"recursive-readdir": "^1.3.0",
"rimraf": "^2.5.0",
@@ -63,4 +62,4 @@
"authors": [
"Caolan McMahon"
]
-} \ No newline at end of file
+}
diff --git a/package.json b/package.json
index 57503fd..ae8cbcd 100644
--- a/package.json
+++ b/package.json
@@ -44,7 +44,6 @@
"karma-mocha-reporter": "^1.0.2",
"mocha": "^2.2.5",
"native-promise-only": "^0.8.0-a",
- "nodeunit": ">0.0.0",
"nyc": "^2.1.0",
"recursive-readdir": "^1.3.0",
"rimraf": "^2.5.0",
@@ -59,12 +58,11 @@
"scripts": {
"coverage": "nyc npm test && nyc report",
"coveralls": "nyc npm test && nyc report --reporter=text-lcov | coveralls",
- "lint": "jshint lib/ test/ mocha_test/ perf/memory.js perf/suites.js perf/benchmark.js support/ karma.conf.js && jscs lib/ test/ mocha_test/ perf/memory.js perf/suites.js perf/benchmark.js support/ karma.conf.js",
+ "lint": "jshint lib/ mocha_test/ perf/memory.js perf/suites.js perf/benchmark.js support/ karma.conf.js && jscs lib/ mocha_test/ perf/memory.js perf/suites.js perf/benchmark.js support/ karma.conf.js",
"mocha-browser-test": "karma start",
"mocha-node-test": "mocha mocha_test/ --compilers js:babel-core/register",
"mocha-test": "npm run mocha-node-test && npm run mocha-browser-test",
- "nodeunit-test": "nodeunit test/test-async.js",
- "test": "npm run-script lint && npm run nodeunit-test && npm run mocha-node-test"
+ "test": "npm run-script lint && npm run mocha-node-test"
},
"license": "MIT",
"jam": {
@@ -91,4 +89,4 @@
"tests"
]
}
-} \ No newline at end of file
+}
diff --git a/test/test-async.js b/test/test-async.js
deleted file mode 100755
index b33bf0f..0000000
--- a/test/test-async.js
+++ /dev/null
@@ -1,6 +0,0 @@
-/**
- * NOTE: We are in the process of migrating these tests to Mocha. If you are
- * adding a new test, please create a new spec file in mocha_tests/
- */
-
-require('babel-core/register');
diff --git a/test/test.html b/test/test.html
deleted file mode 100644
index 0047af4..0000000
--- a/test/test.html
+++ /dev/null
@@ -1,24 +0,0 @@
-<html>
- <head>
- <title>Async.js Test Suite</title>
- <!--
- async must be included after nodeunit because nodeunit already uses
- the async lib internally and will overwrite the version we want to test
- -->
- <script src="../deps/nodeunit.js"></script>
- <script src="../dist/async.js"></script>
- <link rel="stylesheet" href="../deps/nodeunit.css" type="text/css" media="screen" />
- <script>
- var _async = this.async;
- this.require = function () { return _async; };
- this.exports = {};
- </script>
- <script src="test-async.js"></script>
- </head>
- <body>
- <h1 id="nodeunit-header">Async.js Test Suite</h1>
- <script>
- nodeunit.run({'test-async': exports});
- </script>
- </body>
-</html>