summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-06-30 16:34:30 -0700
committerAlexander Early <alexander.early@gmail.com>2016-06-30 16:34:30 -0700
commita42facc6678552277a75c14c0cd78bcb14f714ac (patch)
tree03b9a1d9df1976ceebef69660eb5948cbe388aa0
parentb83ce9494533141505eebff25ef57d66b72ba5ac (diff)
downloadasync-a42facc6678552277a75c14c0cd78bcb14f714ac.tar.gz
make docs publishing fail if there are uncommitted changes
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e180aa9..158a5db 100644
--- a/Makefile
+++ b/Makefile
@@ -121,5 +121,7 @@ release-major release-minor release-patch release-prerelease: all
.PHONY: doc
doc:
+ git diff-files --quiet # fail if unstanged changes
+ git diff-index --quiet HEAD # fail if uncommited changes
npm run-script jsdoc
gh-pages-deploy