summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Nordberg <its@johan-nordberg.com>2016-05-29 12:33:02 +0200
committerJohan Nordberg <its@johan-nordberg.com>2016-05-29 12:33:02 +0200
commit02381795698f522d66138d3865b8cc75772d9104 (patch)
tree4b0e653ed4f278851670bc5f01aaae522adb6159
parentaf6c5956da1d98855a63d34e9c7aa3bb90b4140d (diff)
downloadasync-02381795698f522d66138d3865b8cc75772d9104.tar.gz
Fix Makefile build on OS X
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c1ccdb9..3bc6e9f 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@
# created here are checked in so people on all platforms can run npm scripts.
# This build should be run once per release.
+SHELL=/bin/bash
export PATH := ./node_modules/.bin/:$(PATH):./bin/
PACKAGE = asyncjs
@@ -75,7 +76,7 @@ build-es: $(ES_MODULES)
$(BUILD_ES)/%.js: lib/%.js
mkdir -p "$(@D)"
- sed -r "s/(import.+)lodash/\1lodash-es/g" $< > $@
+ sed -E "s/(import.+)lodash/\1lodash-es/g" $< > $@
test-build:
mocha support/build.test.js