summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Yeates <yeatesgraeme@gmail.com>2016-01-10 16:49:27 -0500
committerGraeme Yeates <yeatesgraeme@gmail.com>2016-01-10 16:49:27 -0500
commit74e44ade0545961559e4a30d0bc43092865da0a0 (patch)
treec3a9f301b5d3038d65d600417b75bbe937786c59
parent1f79497635d63753686779238ba4df01bcad21fb (diff)
downloadasync-74e44ade0545961559e4a30d0bc43092865da0a0.tar.gz
Improve bundle error reporting
-rw-r--r--Makefile8
-rw-r--r--support/build/aggregate-build.js2
2 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 61c2ae8..e423cb6 100644
--- a/Makefile
+++ b/Makefile
@@ -32,10 +32,10 @@ build-bundle:
build-dist:
mkdir -p $(DIST)
- cp $(BUILDDIR)/async-bundle.js $(DIST)/
- $(UGLIFY) $(DIST)/async-bundle.js -mc \
- --source-map $(DIST)/async-bundle.min.map \
- -o $(DIST)/async-bundle.min.js
+ cp $(BUILDDIR)/async-bundle.js $(DIST)/async.js
+ $(UGLIFY) $(DIST)/async.js -mc \
+ --source-map $(DIST)/async.min.map \
+ -o $(DIST)/async.min.js
build: clean build-bundle build-dist
diff --git a/support/build/aggregate-build.js b/support/build/aggregate-build.js
index 63d7799..01b8462 100644
--- a/support/build/aggregate-build.js
+++ b/support/build/aggregate-build.js
@@ -13,7 +13,7 @@ export default function buildBundle(options) {
dest: options.outfile
});
rimraf.sync(options.outpath);
- });
+ }).catch(console.error);
}
compileModules(bundle, options);