summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-02-09 19:30:28 -0800
committerAlexander Early <alexander.early@gmail.com>2016-02-09 19:30:28 -0800
commit34f666a735d68eb563d1ff5d22fc85d176dcdcc2 (patch)
treeefeab36210b24c58c5faae1817fb32d5e84ccbb5 /Makefile
parentf4f2742270bc4c7f1325620bddc804379a8c0486 (diff)
downloadasync-34f666a735d68eb563d1ff5d22fc85d176dcdcc2.tar.gz
move package manager files during build process, update main paths
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 541cb34..ca9fe84 100644
--- a/Makefile
+++ b/Makefile
@@ -75,9 +75,20 @@ $(BUILDDIR)/es/%.js: lib/%.js
test-build:
mocha support/build.test.js
-.PHONY: build-modules build-bundle build-dist build-es test-build
+build-config: $(BUILDDIR)/package.json $(BUILDDIR)/component.json $(BUILDDIR)/bower.json $(BUILDDIR)/README.md $(BUILDDIR)/LICENSE $(BUILDDIR)/CHANGELOG.md
-build: clean build-bundle build-dist build-es test-build
+bower.json: package.json
+ support/sync-package-managers.js
+
+component.json: package.json
+ support/sync-package-managers.js
+
+$(BUILDDIR)/%: %
+ cp $< $@
+
+.PHONY: build-modules build-bundle build-dist build-es build-config test-build
+
+build: clean build-bundle build-dist build-es build-config test-build
.PHONY: test lint build all clean