summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIvan Akulov <iamakulov@outlook.com>2018-03-23 23:21:17 +0300
committerHubert Argasinski <argasinski.hubert@gmail.com>2018-03-23 16:21:17 -0400
commit3235c8f5f67ff38b85ce6f9664053d0b1897ff3b (patch)
tree25918b68061813a242a3e4e8bc1c45f83e982508 /Makefile
parentf5d86b80b986c8cad88a224a6f8b3ec154839490 (diff)
downloadasync-3235c8f5f67ff38b85ce6f9664053d0b1897ff3b.tar.gz
Optimize the library for webpack users (#1517)
* Add the `sideEffects: false` flag into the ES package.json * Add a different Readme for async-es and link across the packages * Fix the wrong method name
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 880d739..770ed1b 100644
--- a/Makefile
+++ b/Makefile
@@ -123,6 +123,10 @@ $(BUILD_ES)/package.json: package.json
mkdir -p "$(@D)"
support/sync-es-package.js > $@
+$(BUILD_ES)/README.md: README.es.md
+ mkdir -p "$(@D)"
+ cp $< $@
+
$(BUILD_ES)/%: %
mkdir -p "$(@D)"
cp $< $@