summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGraeme Yeates <yeatesgraeme@gmail.com>2015-12-29 16:39:20 -0500
committerGraeme Yeates <yeatesgraeme@gmail.com>2015-12-29 17:19:07 -0500
commit90656cfd3b6750397a1f5e9539323391cf0e50c6 (patch)
tree98034c45b789f46bdec3f04e3cdec8b9fb4274c3 /Makefile
parent1448f24a5e7d5c4b9ff56ef573d35291511c2a71 (diff)
downloadasync-90656cfd3b6750397a1f5e9539323391cf0e50c6.tar.gz
Set up async bundles
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4c90871..aa0e844 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@ export PATH := ./node_modules/.bin/:$(PATH):./bin/
PACKAGE = asyncjs
REQUIRE_NAME = async
+NODE = node_modules/babel-cli/bin/babel-node.js
XYZ = node_modules/.bin/xyz --repo git@github.com:caolan/async.git
BROWSERIFY = node_modules/.bin/browserify
@@ -18,7 +19,7 @@ build: $(wildcard lib/*.js)
-o $(BUILDDIR)/async.min.js
test:
- nodeunit test
+ npm test
clean:
rm -rf $(BUILDDIR)
@@ -27,8 +28,14 @@ lint:
jshint $(SRC) test/*.js mocha_test/* perf/*.js
jscs $(SRC) test/*.js mocha_test/* perf/*.js
-.PHONY: test lint build all clean
+submodule-clone:
+ git submodule update --init --recursive
+
+build-bundle: submodule-clone lint test
+ $(NODE) scripts/build/modules-cjs.js
+ $(NODE) scripts/build/aggregate-build.js
+.PHONY: test lint build all clean
.PHONY: release-major release-minor release-patch
release-major release-minor release-patch: all