summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2015-10-24 19:47:30 -0700
committerAlexander Early <alexander.early@gmail.com>2015-10-24 19:47:30 -0700
commitf88e57ce28214d3ad699b40a94ada1eeb638f5c7 (patch)
tree577e6247cf53b0770f7379db71fbdcac4c565df1 /Makefile
parente04b644577bd575e070826a037c6d6e6184c20b3 (diff)
downloadasync-f88e57ce28214d3ad699b40a94ada1eeb638f5c7.tar.gz
simplify makefile, update node versions for travis
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 5d05ce6..2de7e04 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,6 @@
+export PATH := ./node_modules/.bin/:$(PATH):./bin/
+
PACKAGE = asyncjs
-CWD := $(shell pwd)
-NODEUNIT = "$(CWD)/node_modules/.bin/nodeunit"
-UGLIFY = "$(CWD)/node_modules/.bin/uglifyjs"
-JSHINT = "$(CWD)/node_modules/.bin/jshint"
-JSCS = "$(CWD)/node_modules/.bin/jscs"
XYZ = node_modules/.bin/xyz --repo git@github.com:caolan/async.git
BUILDDIR = dist
@@ -14,17 +11,17 @@ all: lint test clean build
build: $(wildcard lib/*.js)
mkdir -p $(BUILDDIR)
cp $(SRC) $(BUILDDIR)/async.js
- cd $(BUILDDIR) && $(UGLIFY) async.js -mc --source-map async.min.map -o async.min.js
+ cd $(BUILDDIR) && uglifyjs async.js -mc --source-map async.min.map -o async.min.js
test:
- $(NODEUNIT) test
+ nodeunit test
clean:
rm -rf $(BUILDDIR)
lint:
- $(JSHINT) $(SRC) test/*.js mocha_test/* perf/*.js
- $(JSCS) $(SRC) test/*.js mocha_test/* perf/*.js
+ jshint $(SRC) test/*.js mocha_test/* perf/*.js
+ jscs $(SRC) test/*.js mocha_test/* perf/*.js
.PHONY: test lint build all clean