summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGraeme Yeates <yeatesgraeme@gmail.com>2016-01-04 10:38:20 -0500
committerGraeme Yeates <yeatesgraeme@gmail.com>2016-01-04 10:38:20 -0500
commit41489b2d8ed5c1677fd77975cecd54b4f60f4334 (patch)
tree2b50cddb64dbca80159693438b8d1a193d7dc43e /Makefile
parent85f5be9ccbd1055178d14162916d9757303d468c (diff)
downloadasync-41489b2d8ed5c1677fd77975cecd54b4f60f4334.tar.gz
Update make build tasks
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 3aa53ba..a2c501a 100644
--- a/Makefile
+++ b/Makefile
@@ -3,11 +3,13 @@ export PATH := ./node_modules/.bin/:$(PATH):./bin/
PACKAGE = asyncjs
REQUIRE_NAME = async
NODE = node_modules/babel-cli/bin/babel-node.js
+UGLIFY = node_modules/.bin/uglifyjs
XYZ = node_modules/.bin/xyz --repo git@github.com:caolan/async.git
-BROWSERIFY = node_modules/.bin/browserify
-BUILDDIR = dist
+BUILDDIR = build
+DIST = dist
SRC = lib/index.js
+SCRIPTS = ./support
all: lint test clean build
@@ -16,6 +18,7 @@ test:
clean:
rm -rf $(BUILDDIR)
+ rm -rf $(DIST)
lint:
jshint $(SRC) test/*.js mocha_test/* perf/*.js
@@ -25,18 +28,24 @@ submodule-clone:
git submodule update --init --recursive
build-bundle: submodule-clone
- $(NODE) scripts/build/modules-cjs.js
- $(NODE) scripts/build/aggregate-bundle.js
- $(NODE) scripts/build/aggregate-cjs.js
+ $(NODE) $(SCRIPTS)/build/modules-cjs.js
+ $(NODE) $(SCRIPTS)/build/aggregate-bundle.js
+ $(NODE) $(SCRIPTS)/build/aggregate-cjs.js
+build-dist:
+ mkdir -p $(DIST)
+ cp $(BUILDDIR)/async-bundle.js $(DIST)/
+ $(UGLIFY) $(DIST)/async-bundle.js -mc \
+ --source-map $(DIST)/async-bundle.min.map \
+ -o $(DIST)/async-bundle.min.js
-build: build-bundle
+build: clean build-bundle build-dist
.PHONY: test lint build all clean
.PHONY: release-major release-minor release-patch
release-major release-minor release-patch: all
- ./support/sync-package-managers.js
+ $(SCRIPTS)/sync-package-managers.js
git add --force *.json
git add --force $(BUILDDIR)
git commit -am "update minified build"; true