summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGraeme Yeates <yeatesgraeme@gmail.com>2016-01-04 09:10:08 -0500
committerGraeme Yeates <yeatesgraeme@gmail.com>2016-01-04 09:10:08 -0500
commit85f5be9ccbd1055178d14162916d9757303d468c (patch)
tree9afd7dd7ebaea267428feb428f55e818ce9875a9 /Makefile
parent08af90ee6d5ef09447b5abfb0cfb6fcff35ecb2e (diff)
downloadasync-85f5be9ccbd1055178d14162916d9757303d468c.tar.gz
Avoid including lodash string parsing in bundle
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index d8cd746..3aa53ba 100644
--- a/Makefile
+++ b/Makefile
@@ -11,13 +11,6 @@ SRC = lib/index.js
all: lint test clean build
-build: $(wildcard lib/*.js)
- mkdir -p $(BUILDDIR)
- browserify $(SRC) -o $(BUILDDIR)/async.js -s $(REQUIRE_NAME)
- uglifyjs $(BUILDDIR)/async.js -mc \
- --source-map $(BUILDDIR)/async.min.map \
- -o $(BUILDDIR)/async.min.js
-
test:
npm test
@@ -31,11 +24,14 @@ lint:
submodule-clone:
git submodule update --init --recursive
-build-bundle: #submodule-clone lint test
+build-bundle: submodule-clone
$(NODE) scripts/build/modules-cjs.js
$(NODE) scripts/build/aggregate-bundle.js
$(NODE) scripts/build/aggregate-cjs.js
+
+build: build-bundle
+
.PHONY: test lint build all clean
.PHONY: release-major release-minor release-patch