summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-06-30 16:27:48 -0700
committerAlexander Early <alexander.early@gmail.com>2016-06-30 16:27:48 -0700
commitb83ce9494533141505eebff25ef57d66b72ba5ac (patch)
tree694b5b584901a84406992bcb9efb3e39f2aa677f /Makefile
parent98d3736f60d5bf0d2c5f83a130a8275fc46bb53d (diff)
downloadasync-b83ce9494533141505eebff25ef57d66b72ba5ac.tar.gz
add docs publishing script. Related to #1202
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 701f27d..e180aa9 100644
--- a/Makefile
+++ b/Makefile
@@ -117,3 +117,9 @@ release-major release-minor release-patch release-prerelease: all
$(MAKE) build-es-config
cd build/ && npm publish
cd build-es/ && npm publish
+ $(MAKE) doc
+
+.PHONY: doc
+doc:
+ npm run-script jsdoc
+ gh-pages-deploy