diff options
author | megawac <megawac@gmail.com> | 2015-07-19 21:25:19 -0400 |
---|---|---|
committer | megawac <megawac@gmail.com> | 2015-07-19 21:25:19 -0400 |
commit | 5645eeec033816c616de8ec25946ea7734743e22 (patch) | |
tree | ae0eec5cb067e84a19c0b853e504efdf6ef0c3fa /Makefile | |
parent | b0fe15781893bb605b90ced4204175026640b033 (diff) | |
download | async-5645eeec033816c616de8ec25946ea7734743e22.tar.gz |
Revert build dir to dist/ and add async.js to folder
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -6,13 +6,15 @@ JSHINT = "$(CWD)/node_modules/.bin/jshint" JSCS = "$(CWD)/node_modules/.bin/jscs" XYZ = node_modules/.bin/xyz --repo git@github.com:caolan/async.git -BUILDDIR = lib +BUILDDIR = dist +SRC = lib/async.js all: clean test build build: $(wildcard lib/*.js) mkdir -p $(BUILDDIR) - $(UGLIFY) lib/async.js -mc > $(BUILDDIR)/async.min.js + $(UGLIFY) $(SRC) -mc > $(BUILDDIR)/async.min.js + cp $(SRC) $(BUILDDIR)/async.js test: $(NODEUNIT) test @@ -21,8 +23,8 @@ clean: rm -rf $(BUILDDIR) lint: - $(JSHINT) lib/*.js test/*.js perf/*.js - $(JSCS) lib/*.js test/*.js perf/*.js + $(JSHINT) $(SRC) test/*.js perf/*.js + $(JSCS) $(SRC) test/*.js perf/*.js .PHONY: test lint build all clean |