summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
author--global <alexander.early@gmail.com>2016-01-15 17:59:41 -0800
committer--global <alexander.early@gmail.com>2016-01-15 17:59:41 -0800
commitaf0a2edfab9ded3f32165c6cfac0389b852a2071 (patch)
tree71b24da7bcf737c1bf973466de77770cba219bd5 /Makefile
parentf984553b9d5a2d4600b599ec6746c459707c7338 (diff)
downloadasync-af0a2edfab9ded3f32165c6cfac0389b852a2071.tar.gz
rename build files, add smoke test for build
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 35cf101..73ea64d 100644
--- a/Makefile
+++ b/Makefile
@@ -13,14 +13,17 @@ SCRIPTS = ./support
JS_SRC = $(shell find lib/ -type f -name '*.js') package.json
LINT_FILES = lib/ test/ mocha_test/ $(shell find perf/ -maxdepth 2 -type f) support/ gulpfile.js karma.conf.js
-UMD_BUNDLE = $(BUILDDIR)/async-bundle.js
-CJS_BUNDLE = $(BUILDDIR)/async-cjs.js
+UMD_BUNDLE = $(BUILDDIR)/async.js
+CJS_BUNDLE = $(BUILDDIR)/index.js
all: lint test clean build
test:
npm test
+test-build: build
+ mocha support/build.test.js
+
clean:
rm -rf $(BUILDDIR)
rm -rf $(DIST)
@@ -45,7 +48,7 @@ $(CJS_BUNDLE): $(JS_SRC)
build-dist:
mkdir -p $(DIST)
- cp $(BUILDDIR)/async-bundle.js $(DIST)/async.js
+ cp $(BUILDDIR)/async.js $(DIST)/async.js
$(UGLIFY) $(DIST)/async.js -mc \
--source-map $(DIST)/async.min.map \
-o $(DIST)/async.min.js