summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2016-02-10 16:00:17 -0800
committerAlexander Early <alexander.early@gmail.com>2016-02-10 16:00:17 -0800
commit8423f0bec47e0f6ff3652954b5ccb303fc72aeb8 (patch)
treea28818d8b3b71c36d1a30c87775fdd48863d7191 /Makefile
parentb001e4a9c3e51bf277d69b54e5776caa7099a455 (diff)
downloadasync-8423f0bec47e0f6ff3652954b5ccb303fc72aeb8.tar.gz
use tweaked version of xyz for our publish process
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index ca9fe84..df798bd 100644
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,7 @@ PACKAGE = asyncjs
REQUIRE_NAME = async
BABEL_NODE = babel-node
UGLIFY = uglifyjs
-XYZ = xyz --repo git@github.com:caolan/async.git
+XYZ = support/xyz.sh --repo git@github.com:caolan/async.git
BUILDDIR = build
DIST = dist
@@ -23,7 +23,7 @@ CJS_BUNDLE = $(BUILDDIR)/index.js
ES_MODULES = $(patsubst lib/%.js, build/es/%.js, $(JS_SRC))
-all: lint test clean build
+all: clean lint build test
test:
npm test
@@ -94,8 +94,6 @@ build: clean build-bundle build-dist build-es build-config test-build
.PHONY: release-major release-minor release-patch
release-major release-minor release-patch: all
- $(SCRIPTS)/sync-package-managers.js
- git add --force *.json
git add --force $(BUILDDIR)
git commit -am "update minified build"; true
$(XYZ) --increment $(@:release-%=%)