summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorCaolan McMahon <caolan@caolanmcmahon.com>2010-11-17 18:58:16 +0000
committerCaolan McMahon <caolan@caolanmcmahon.com>2010-11-17 18:58:16 +0000
commit54f563a9b6775ba476313c3659c6a02b8893b472 (patch)
treeaca30f15a34c3a105593010d4e0b6d1a7e69c264 /Makefile
parent3346146231683ca27cece79c53dcd71d40a04bcb (diff)
downloadasync-54f563a9b6775ba476313c3659c6a02b8893b472.tar.gz
added makefile with lint, test and build targets
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..00f07ea
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+PACKAGE = asyncjs
+NODEJS = $(if $(shell test -f /usr/bin/nodejs && echo "true"),nodejs,node)
+
+BUILDDIR = dist
+
+all: build
+
+build: $(wildcard lib/*.js)
+ mkdir -p $(BUILDDIR)
+ uglifyjs lib/async.js > $(BUILDDIR)/async.min.js
+
+test:
+ nodeunit test
+
+clean:
+ rm -rf $(BUILDDIR)
+
+lint:
+ nodelint --config nodelint.cfg lib/async.js
+
+.PHONY: test build all