summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index bad647c..4356239 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,8 @@
PACKAGE = asyncjs
-NODEJS = $(if $(shell test -f /usr/bin/nodejs && echo "true"),nodejs,node)
CWD := $(shell pwd)
-NODEUNIT = $(CWD)/node_modules/nodeunit/bin/nodeunit
-UGLIFY = $(CWD)/node_modules/uglify-js/bin/uglifyjs
-NODELINT = $(CWD)/node_modules/nodelint/nodelint
+NODEUNIT = "$(CWD)/node_modules/.bin/nodeunit"
+UGLIFY = "$(CWD)/node_modules/.bin/uglifyjs"
+JSHINT = "$(CWD)/node_modules/.bin/jshint"
BUILDDIR = dist
@@ -20,6 +19,6 @@ clean:
rm -rf $(BUILDDIR)
lint:
- $(NODELINT) --config nodelint.cfg lib/async.js
+ $(JSHINT) lib/*.js test/*.js perf/*.js
-.PHONY: test build all
+.PHONY: test lint build all clean