summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 35f4c38..6609aa6 100644
--- a/Makefile
+++ b/Makefile
@@ -6,13 +6,15 @@ JSHINT = "$(CWD)/node_modules/.bin/jshint"
JSCS = "$(CWD)/node_modules/.bin/jscs"
XYZ = node_modules/.bin/xyz --repo git@github.com:caolan/async.git
-BUILDDIR = lib
+BUILDDIR = dist
+SRC = lib/async.js
-all: clean test build
+all: lint test clean build
build: $(wildcard lib/*.js)
mkdir -p $(BUILDDIR)
- $(UGLIFY) lib/async.js -mc > $(BUILDDIR)/async.min.js
+ cp $(SRC) $(BUILDDIR)/async.js
+ cd $(BUILDDIR) && $(UGLIFY) async.js -mc --source-map async.min.map -o async.min.js
test:
$(NODEUNIT) test
@@ -21,8 +23,8 @@ clean:
rm -rf $(BUILDDIR)
lint:
- $(JSHINT) lib/*.js test/*.js perf/*.js
- $(JSCS) lib/*.js test/*.js perf/*.js
+ $(JSHINT) $(SRC) test/*.js perf/*.js
+ $(JSCS) $(SRC) test/*.js perf/*.js
.PHONY: test lint build all clean
@@ -31,5 +33,5 @@ lint:
release-major release-minor release-patch: all
./support/sync-package-managers.js
git add --force $(BUILDDIR)
- git ci -am "update minified build"
+ git commit -am "update minified build"
@$(XYZ) --increment $(@:release-%=%)