summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Yurchak <rth.yurchak@pm.me>2019-10-10 18:02:01 +0200
committerEric Larson <larson.eric.d@gmail.com>2019-10-23 01:09:06 -0400
commitea8a4e4e4831ec942ede232f56810acbabf2feb2 (patch)
treede31addfb1c589dee82e0c23ff877e63910ef004 /setup.py
parentaa290a10d28a085213fa283340da2ed4e1660bab (diff)
downloadnumpydoc-ea8a4e4e4831ec942ede232f56810acbabf2feb2.tar.gz
Drop Python 2.7 and 3.4 support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 6 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 87076c7..64e432f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,3 @@
-from __future__ import division, print_function
-
import sys
import os
@@ -9,8 +7,8 @@ from distutils.core import setup
from numpydoc import __version__ as version
-if sys.version_info[:2] < (2, 7) or (3, 0) <= sys.version_info[0:2] < (3, 4):
- raise RuntimeError("Python version 2.7 or >= 3.4 required.")
+if sys.version_info < (3, 5):
+ raise RuntimeError("Python version >= 3.5 required.")
def read(fname):
@@ -36,18 +34,18 @@ setup(
"License :: OSI Approved :: BSD License",
"Topic :: Documentation",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6"],
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ ],
keywords="sphinx numpy",
author="Pauli Virtanen and others",
author_email="pav@iki.fi",
url="https://numpydoc.readthedocs.io",
license="BSD",
install_requires=["sphinx >= 1.6.5", 'Jinja2>=2.3'],
+ python_requires=">=3.5",
package_data={'numpydoc': [
'tests/test_*.py',
'tests/tinybuild/Makefile',