summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAllen Martin <amartin@nvidia.com>2012-03-22 14:12:39 -0700
committerAllen Martin <amartin@nvidia.com>2012-04-03 09:28:16 -0700
commit80b43dbd4f50b92db349c14b5833c177ece4a6df (patch)
tree032627c168410fd66df230b2c09da498343a1381 /src/Makefile.am
parent080ce0cdbe8d6a8bcc9c8864d8d1b891ab0bc93e (diff)
downloadtegrarcm-80b43dbd4f50b92db349c14b5833c177ece4a6df.tar.gz
tegra-rcm: Download code to tegra in recovery mode
This program is used to download BCT and code to tegra from recovery mode. Only tegras that are configurated for "nvproduction" or "ODM open" mode are supported (no encryption). usage: tegra-rcm --bct=bctfile --bootloader=blfile --loadaddr=<loadaddr> --entryaddr=<entryaddr> bctfile is the name of the BCT (boot configuration table). It contains memory timing and boot device selection. blfile is the name of the booloader file. This is the code that downloaded and executed on the tegra SoC. loadaddr and entryaddr are the load and entry addresses of the bootloader in the tegra address map. Change-Id: I34754d3976f3971bdca1daefc5d1a2c69a56bbb5 Reviewed-on: http://git-master/r/94264 Reviewed-by: Allen Martin <amartin@nvidia.com> Tested-by: Allen Martin <amartin@nvidia.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..3e8ec33
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,7 @@
+AM_CFLAGS = -Wall -std=c99 -O2
+AM_CPPFLAGS = -isystem /usr/include/cryptopp
+
+bin_PROGRAMS = tegrarcm
+tegrarcm_SOURCES = main.c usb.c nv3p.c debug.c rcm.c aes-cmac.cpp aes-cmac.h debug.h nv3p.h nv3p_status.h rcm.h tegra2-miniloader.h tegra3-miniloader.h usb.h
+tegrarcm_LDADD = -lusb-1.0 -lcryptopp -lpthread
+