summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-01-30 08:28:14 -0800
committerMarcel Holtmann <marcel@holtmann.org>2010-01-30 08:28:14 -0800
commit1f23ed257bc48f9d3b6b476a8ecee556763d7202 (patch)
treefda860867a83fefc7dc8d55fca6801d763b543dd /configure.ac
parentc47a3c599d127f0c71d6e2474b0fd5174490a7fb (diff)
downloadobexd-1f23ed257bc48f9d3b6b476a8ecee556763d7202.tar.gz
Check for dbus_connection_can_send_type() function
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b93c6b..ba0f8a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,9 @@ PKG_CHECK_MODULES(DBUS, dbus-1, dummy=yes,
AC_CHECK_LIB(dbus-1, dbus_watch_get_unix_fd, dummy=yes,
AC_DEFINE(NEED_DBUS_WATCH_GET_UNIX_FD, 1,
[Define to 1 if you need the dbus_watch_get_unix_fd() function.]))
+AC_CHECK_LIB(dbus-1, dbus_connection_can_send_type, dummy=yes,
+ AC_DEFINE(NEED_DBUS_CONNECTION_CAN_SEND_TYPE, 1,
+ [Define to 1 if you need the dbus_connection_can_send_type() funnction.]))
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)