summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-09-29 19:51:28 +0900
committerMarcel Holtmann <marcel@holtmann.org>2010-09-29 20:00:18 +0900
commit1f2349ee0b07244cec2fa721a15e7ff22344a044 (patch)
tree2bbeb7de24469d7afd11ed4f459d86439398f4f2 /configure.ac
parent94fb2f23f83b96016df3e371b08a3f12276f77fe (diff)
downloadofono-1f2349ee0b07244cec2fa721a15e7ff22344a044.tar.gz
Sort enable configure option before the disable ones
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 74c8fc28..f34b9d47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,16 @@ else
fi
AC_SUBST(DBUS_CONFDIR)
+AC_ARG_ENABLE(capng, AC_HELP_STRING([--enable-capng],
+ [enable capabilities support]), [enable_capng=${enableval}])
+if (test "${enable_capng}" = "yes"); then
+ PKG_CHECK_MODULES(CAPNG, libcap-ng, dummy=yes,
+ AC_MSG_ERROR(Capabilities library is required))
+ AC_SUBST(CAPNG_CFLAGS)
+ AC_SUBST(CAPNG_LIBS)
+ AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
+fi
+
AC_ARG_ENABLE(udev, AC_HELP_STRING([--disable-udev],
[don't use udev support even if available]),
[enable_udev=${enableval}])
@@ -120,16 +130,6 @@ AC_SUBST(UDEV_CFLAGS)
AC_SUBST(UDEV_LIBS)
AM_CONDITIONAL(UDEV, test "${enable_udev}" = "yes")
-AC_ARG_ENABLE(capng, AC_HELP_STRING([--enable-capng],
- [enable capabilities support]), [enable_capng=${enableval}])
-if (test "${enable_capng}" = "yes"); then
- PKG_CHECK_MODULES(CAPNG, libcap-ng, dummy=yes,
- AC_MSG_ERROR(Capabilities library is required))
- AC_SUBST(CAPNG_CFLAGS)
- AC_SUBST(CAPNG_LIBS)
- AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
-fi
-
AC_ARG_ENABLE(isimodem, AC_HELP_STRING([--disable-isimodem],
[disable PhoNet/ISI modem support]),
[enable_isimodem=${enableval}])