summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2013-06-11 11:26:10 +1000
committerDarren Tucker <dtucker@zip.com.au>2013-06-11 11:26:10 +1000
commit6d8bd57448b45b42809da32857d7804444349ee7 (patch)
tree6c693d94198b7df2157202405964151847e50251 /configure.ac
parent36187093ea0b2d2240c043417b8949611687e105 (diff)
downloadopenssh-git-6d8bd57448b45b42809da32857d7804444349ee7.tar.gz
- (dtucker) [Makefile.in configure.ac fixalgorithms] Remove unsupported
algorithms (Ciphers, MACs and HostKeyAlgorithms) from man pages.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index bce5d7b1..e6ec2768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.534 2013/06/05 22:30:21 dtucker Exp $
+# $Id: configure.ac,v 1.535 2013/06/11 01:26:10 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
-AC_REVISION($Revision: 1.534 $)
+AC_REVISION($Revision: 1.535 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_LANG([C])
@@ -2394,6 +2394,8 @@ AC_LINK_IFELSE(
],
[
AC_MSG_RESULT([no])
+ unsupported_algorithms="$unsupported_cipers \
+ aes128-gcm@openssh.com aes256-gcm@openssh.com"
]
)
@@ -2434,8 +2436,15 @@ fi
AC_CHECK_FUNCS([crypt DES_crypt])
# Search for SHA256 support in libc and/or OpenSSL
-AC_CHECK_FUNCS([SHA256_Update EVP_sha256], [TEST_SSH_SHA256=yes],
- [TEST_SSH_SHA256=no])
+AC_CHECK_FUNCS([SHA256_Update EVP_sha256],
+ [TEST_SSH_SHA256=yes],
+ [TEST_SSH_SHA256=no
+ unsupported_algorithms="$unsupported_algorithms \
+ hmac-sha2-256 hmac-sha2-512 \
+ diffie-hellman-group-exchange-sha256 \
+ hmac-sha2-256-etm@openssh.com hmac-sha2-512-etm@openssh.com"
+ ]
+)
AC_SUBST([TEST_SSH_SHA256])
# Check complete ECC support in OpenSSL
@@ -2466,6 +2475,12 @@ AC_LINK_IFELSE(
AC_MSG_RESULT([no])
TEST_SSH_ECC=no
COMMENT_OUT_ECC="#no ecc#"
+ unsupported_algorithms="$unsupported_algorithms \
+ ecdh-sha2-nistp256 ecdh-sha2-nistp384 ecdh-sha2-nistp521 \
+ ecdsa-sha2-nistp256-cert-v01@openssh.com \
+ ecdsa-sha2-nistp384-cert-v01@openssh.com \
+ ecdsa-sha2-nistp521-cert-v01@openssh.com \
+ ecdsa-sha2-nistp256 ecdsa-sha2-nistp384 ecdsa-sha2-nistp521"
]
)
AC_SUBST([TEST_SSH_ECC])
@@ -4541,6 +4556,7 @@ else
fi
AC_CHECK_DECL([BROKEN_GETADDRINFO], [TEST_SSH_IPV6=no])
AC_SUBST([TEST_SSH_IPV6], [$TEST_SSH_IPV6])
+AC_SUBST([UNSUPPORTED_ALGORITHMS], [$unsupported_algorithms])
AC_EXEEXT
AC_CONFIG_FILES([Makefile buildpkg.sh opensshd.init openssh.xml \