summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2002-04-12 10:26:21 -0700
committerTim Rice <tim@multitalents.net>2002-04-12 10:26:21 -0700
commitae49fe64ca7fe592f3c1cc6b5647c9cc60a4b49c (patch)
tree295ae3db40778e60f2a05d3c9f9bc1a689e82da3 /configure.ac
parent19fa9b544f0b25603517b771f6c36b630021e932 (diff)
downloadopenssh-git-ae49fe64ca7fe592f3c1cc6b5647c9cc60a4b49c.tar.gz
[configure.ac] add <sys/types.h> to msghdr tests.
Change -L to -h on testing for /bin being symbolic link
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ce4e2958..c0cce4bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.42 2002/04/10 23:17:05 stevesk Exp $
+# $Id: configure.ac,v 1.43 2002/04/12 17:26:23 tim Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1015,7 +1015,7 @@ AC_DEFINE_UNQUOTED(SSH_PRIVSEP_USER, "$ssh_privsep_user")
OPATH=$PATH
PATH=/bin:/usr/bin
-/bin/test -L /bin 2> /dev/null && PATH=/usr/bin
+test -h /bin 2> /dev/null && PATH=/usr/bin
test -d /sbin && PATH=$PATH:/sbin
test -d /usr/sbin && PATH=$PATH:/usr/sbin
PATH=$PATH:/etc:$OPATH
@@ -1580,6 +1580,7 @@ AC_CACHE_CHECK([for msg_accrights field in struct msghdr],
ac_cv_have_accrights_in_msghdr, [
AC_TRY_COMPILE(
[
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/uio.h>
],
@@ -1596,6 +1597,7 @@ AC_CACHE_CHECK([for msg_control field in struct msghdr],
ac_cv_have_control_in_msghdr, [
AC_TRY_COMPILE(
[
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/uio.h>
],