summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-01-06 12:03:12 +1100
committerDamien Miller <djm@mindrot.org>2000-01-06 12:03:12 +1100
commit1808f38e04dc386bd2caacffe0192d62c1a70286 (patch)
treecace20a20ba0837b347241ae23aa4f428245b9fc /configure.in
parent62ab38ab9e5bae5b516ff10ab62ef55a2592059a (diff)
downloadopenssh-git-1808f38e04dc386bd2caacffe0192d62c1a70286.tar.gz
- Fixed annoying DES corruption problem. libcrypt has been
overriding symbols in libcrypto. Removed libcrypt and crypt.h altogether (libcrypto includes its own crypt(1) replacement) - Added platform-specific rules for Irix 6.x. Included warning that they are untested.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 34c4dfaf..7480349a 100644
--- a/configure.in
+++ b/configure.in
@@ -61,8 +61,11 @@ case "$host" in
AC_DEFINE(USE_UTMPX)
;;
*-*-irix5*)
- AC_DEFINE(CRYPT_H_BREAKS_BUILD)
-# CFLAGS="$CFLAGS -shared"
+ no_libsocket=1
+ no_libnsl=1
+ ;;
+*-*-irix6*)
+ AC_MSG_WARN([*** Irix 6.x is not tested *** ])
no_libsocket=1
no_libnsl=1
;;
@@ -106,7 +109,6 @@ dnl Checks for libraries.
AC_CHECK_LIB(crypto, CRYPTO_lock, ,AC_MSG_ERROR([*** libcrypto missing - please install first ***]))
AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***]))
AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil")
-AC_CHECK_LIB(crypt, crypt, , )
if test -z "$no_libsocket" ; then
AC_CHECK_LIB(nsl, yp_match, , )
@@ -116,7 +118,7 @@ if test -z "$no_libnsl" ; then
fi
dnl Checks for header files.
-AC_CHECK_HEADERS(bstring.h crypt.h endian.h lastlog.h login.h maillock.h netdb.h netgroup.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stropts.h sys/time.h sys/ttcompat.h util.h utmp.h utmpx.h)
+AC_CHECK_HEADERS(bstring.h endian.h lastlog.h login.h maillock.h netdb.h netgroup.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stropts.h sys/time.h sys/ttcompat.h util.h utmp.h utmpx.h)
dnl Checks for library functions.
AC_CHECK_FUNCS(arc4random getpagesize _getpty innetgr md5_crypt mkdtemp openpty setenv seteuid setlogin setproctitle setreuid snprintf strlcat strlcpy updwtmpx vsnprintf)