summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-04-30 00:47:29 +1000
committerDamien Miller <djm@mindrot.org>2000-04-30 00:47:29 +1000
commit1bead335d7381b553bc4a13b3ea2b9dc09679123 (patch)
tree4ea95a94ee08154c459c92452062c00d64bb2170 /configure.in
parenteba71bab9bf01c0d688f829a8971f902732558df (diff)
downloadopenssh-git-1bead335d7381b553bc4a13b3ea2b9dc09679123.tar.gz
- Merge HP-UX fixes and TCB support from Ged Lodder <lodder@yacc.com.au>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 095c9673..fbf117b9 100644
--- a/configure.in
+++ b/configure.in
@@ -56,6 +56,28 @@ case "$host" in
MANTYPE='$(CATMAN)'
mansubdir=cat
;;
+*-*-hpux11*)
+ if test -z "$GCC"; then
+ CFLAGS="$CFLAGS -Ae"
+ fi
+ CFLAGS="$CFLAGS -D_HPUX_SOURCE"
+ CFLAGS="$CFLAGS -I/usr/local/include"
+ LDFLAGS="$LDFLAGS -L/usr/local/lib"
+ AC_DEFINE(IPADDR_IN_DISPLAY)
+ AC_DEFINE(USE_UTMPX)
+ AC_MSG_CHECKING(for HPUX trusted system password database)
+ if test -f /tcb/files/auth/system/default; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_HPUX_TRUSTED_SYSTEM_PW)
+ LIBS="$LIBS -lsec"
+ AC_MSG_WARN([This configuration is untested])
+ else
+ AC_MSG_RESULT(no)
+ AC_DEFINE(DISABLE_SHADOW)
+ fi
+ MANTYPE='$(CATMAN)'
+ mansubdir=cat
+ ;;
*-*-irix5*)
CFLAGS="$CFLAGS -I/usr/local/include"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
@@ -140,6 +162,8 @@ if test -z "$no_pam" -a "x$ac_cv_header_security_pam_appl_h" = "xyes" ; then
AC_CHECK_LIB(dl, dlopen, , )
LIBS="$LIBS -lpam"
+ AC_CHECK_FUNC(pam_getenvlist)
+
# Check PAM strerror arguments (old PAM)
AC_MSG_CHECKING([whether pam_strerror takes only one argument])
AC_TRY_COMPILE(