summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-06-04 15:51:47 +1000
committerDamien Miller <djm@mindrot.org>2000-06-04 15:51:47 +1000
commit2994e0891bae2276259d00fe1cce32323a3fbc66 (patch)
treefbb006cd56076e132513fbd44a38b2415c4435c4 /configure.in
parent60f3c983cc7314fe7e488e75be653974080f9de5 (diff)
downloadopenssh-git-2994e0891bae2276259d00fe1cce32323a3fbc66.tar.gz
- Configure tweaking for new login code on Irix 5.3
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 27 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index cab5b7ac..8056ada0 100644
--- a/configure.in
+++ b/configure.in
@@ -936,19 +936,38 @@ AC_TRY_COMPILE([
#ifdef HAVE_LASTLOG_H
# include <lastlog.h>
#endif
-#ifdef PATHS_H
+#ifdef HAVE_PATHS_H
# include <paths.h>
#endif
],
[ char *lastlog = LASTLOG_FILE; ],
[ AC_MSG_RESULT(yes) ],
- [ AC_MSG_RESULT(no)
- system_lastlog_path=no ]
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING([if your system defines _PATH_LASTLOG])
+ AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <utmp.h>
+#ifdef HAVE_LASTLOG_H
+# include <lastlog.h>
+#endif
+#ifdef HAVE_PATHS_H
+# include <paths.h>
+#endif
+ ],
+ [ char *lastlog = _PATH_LASTLOG; ],
+ [ AC_MSG_RESULT(yes) ],
+ [
+ AC_MSG_RESULT(no),
+ system_lastlog_path=no
+ ])
+ ]
)
+
if test -z "$conf_lastlog_location"; then
if test x"$system_lastlog_path" = x"no" ; then
for f in /var/log/lastlog /usr/adm/lastlog /var/adm/lastlog /etc/security/lastlog ; do
- if test -e $f ; then
+ if test -d "$f" -o -e "$f" ; then
conf_lastlog_location=$f
fi
done
@@ -968,7 +987,7 @@ AC_MSG_CHECKING([if your system defines UTMP_FILE])
AC_TRY_COMPILE([
#include <sys/types.h>
#include <utmp.h>
-#ifdef PATHS_H
+#ifdef HAVE_PATHS_H
# include <paths.h>
#endif
],
@@ -998,7 +1017,7 @@ AC_MSG_CHECKING([if your system defines WTMP_FILE])
AC_TRY_COMPILE([
#include <sys/types.h>
#include <utmp.h>
-#ifdef PATHS_H
+#ifdef HAVE_PATHS_H
# include <paths.h>
#endif
],
@@ -1034,7 +1053,7 @@ AC_TRY_COMPILE([
#ifdef HAVE_UTMPX_H
#include <utmpx.h>
#endif
-#ifdef PATHS_H
+#ifdef HAVE_PATHS_H
# include <paths.h>
#endif
],
@@ -1059,7 +1078,7 @@ AC_TRY_COMPILE([
#ifdef HAVE_UTMPX_H
#include <utmpx.h>
#endif
-#ifdef PATHS_H
+#ifdef HAVE_PATHS_H
# include <paths.h>
#endif
],