summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2001-01-09 00:50:29 +0000
committerBen Lindstrom <mouring@eviladmin.org>2001-01-09 00:50:29 +0000
commit0d5af6017e4549c8b622b505c6a7dd80b24df512 (patch)
tree71a17212ff1668a39c826fd64f1ecacdeba2f760 /configure.in
parent48bd7c118a25b950842864c7eb87ef666cbc342d (diff)
downloadopenssh-git-0d5af6017e4549c8b622b505c6a7dd80b24df512.tar.gz
- (bal) Detect if clock_t structure exists, if not define it.
- (bal) Detect if O_NONBLOCK exists, if not define it. - (bal) removed news4-posix.h (now empty) - (bal) changed bsd-bindresvport.c and bsd-rresvport.c to use 'socklen_t' instead of 'int'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dd68daeb..4730d3c4 100644
--- a/configure.in
+++ b/configure.in
@@ -694,6 +694,20 @@ if test "x$ac_cv_have_ssize_t" = "xyes" ; then
AC_DEFINE(HAVE_SSIZE_T)
fi
+AC_CACHE_CHECK([for clock_t], ac_cv_have_clock_t, [
+ AC_TRY_COMPILE(
+ [
+#include <time.h>
+ ],
+ [ clock_t foo; foo = 1235; ],
+ [ ac_cv_have_clock_t="yes" ],
+ [ ac_cv_have_clock_t="no" ]
+ )
+])
+if test "x$ac_cv_have_clock_t" = "xyes" ; then
+ AC_DEFINE(HAVE_CLOCK_T)
+fi
+
AC_CACHE_CHECK([for sa_family_t], ac_cv_have_sa_family_t, [
AC_TRY_COMPILE(
[