summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordtucker <dtucker>2005-02-09 11:12:30 +0000
committerdtucker <dtucker>2005-02-09 11:12:30 +0000
commit44e80a6572764af6e4e190f7275ad7cc41fd9077 (patch)
treeb4a13ba41a92e96a49a8471f8c756768fb021c3f /configure.ac
parent77e0352a07ffd46dcb26d2c48b1eb312b1133ee7 (diff)
downloadopenssh-44e80a6572764af6e4e190f7275ad7cc41fd9077.tar.gz
- (dtucker) [configure.ac] Bug #854: prepend pwd to relative --with-ssl-dir
paths. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 86b26daf..3ccbbaf0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.237 2005/02/02 12:30:25 dtucker Exp $
+# $Id: configure.ac,v 1.238 2005/02/09 11:12:31 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -1226,6 +1226,10 @@ AC_ARG_WITH(ssl-dir,
[ --with-ssl-dir=PATH Specify path to OpenSSL installation ],
[
if test "x$withval" != "xno" ; then
+ case "$withval" in
+ # Relative paths
+ ./*|../*) withval="`pwd`/$withval"
+ esac
if test -d "$withval/lib"; then
if test -n "${need_dash_r}"; then
LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"