summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-02-20 13:50:00 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-02-20 13:50:00 +0000
commita0997c70e8f988eca678b9da7d0365046a296223 (patch)
tree76478b54527991e4d6e84d72142cfeb8c4ac5da2 /setup.py
parent55a829c1cda58a4ea280a0d88cfaa7ff207c0eab (diff)
downloadceilometermiddleware-a0997c70e8f988eca678b9da7d0365046a296223.tar.gz
Updated from global requirements
Change-Id: Ibc6c73369fa7ba9b9f0219544866b92b51458d97
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)