diff options
author | Doug Hellmann <doug.hellmann@dreamhost.com> | 2013-06-11 14:01:44 -0400 |
---|---|---|
committer | Doug Hellmann <doug.hellmann@dreamhost.com> | 2013-06-11 14:01:44 -0400 |
commit | b8b0c219772bcd93e4c2f9b3cd8022d89d566743 (patch) | |
tree | ce9d237da96ad7f5800b35680872f92daa4cc3a6 /setup.py | |
parent | e9cecc93f15d02fc05a43865356c0bc2f7b9f88e (diff) | |
download | cliff-b8b0c219772bcd93e4c2f9b3cd8022d89d566743.tar.gz |
fix flake8 issues with setup.py
Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 26 |
1 files changed, 12 insertions, 14 deletions
@@ -32,7 +32,7 @@ else: install_requires.append('pyparsing>=2.0.0') try: - import argparse + import argparse # noqa except ImportError: install_requires.append('argparse') @@ -47,13 +47,11 @@ standard_exclude_directories = ('.*', 'CVS', '_darcs', './build', './dist', 'EGG-INFO', '*.egg-info') -def find_package_data( - where='.', package='', - exclude=standard_exclude, - exclude_directories=standard_exclude_directories, - only_in_packages=True, - show_ignored=False, - ): +def find_package_data(where='.', package='', + exclude=standard_exclude, + exclude_directories=standard_exclude_directories, + only_in_packages=True, + show_ignored=False): """ Return a dictionary suitable for use in ``package_data`` in a distutils ``setup.py`` file. @@ -93,7 +91,7 @@ def find_package_data( bad_name = False for pattern in exclude_directories: if (fnmatchcase(name, pattern) - or fn.lower() == pattern.lower()): + or fn.lower() == pattern.lower()): bad_name = True if show_ignored: print >> sys.stderr, ( @@ -118,7 +116,7 @@ def find_package_data( bad_name = False for pattern in exclude: if (fnmatchcase(name, pattern) - or fn.lower() == pattern.lower()): + or fn.lower() == pattern.lower()): bad_name = True if show_ignored: print >> sys.stderr, ( @@ -180,12 +178,12 @@ setup( 'cliff.formatter.list': [ 'table = cliff.formatters.table:TableFormatter', 'csv = cliff.formatters.commaseparated:CSVLister', - ], + ], 'cliff.formatter.show': [ 'table = cliff.formatters.table:TableFormatter', 'shell = cliff.formatters.shell:ShellFormatter', - ], - }, + ], + }, zip_safe=False, - ) +) |