summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-01 13:44:26 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-01 13:44:26 +0000
commit1f5730d9933ff0ccc3da76a999589afba92207fb (patch)
tree97c0b3f35f22eee602ca4563b940712f5c9f8a21 /setup.py
parent53eb11604b71740c83d49937c17fe6098c579253 (diff)
downloadhorizon-1f5730d9933ff0ccc3da76a999589afba92207fb.tar.gz
Updated from global requirements
Change-Id: If8e08b4fb3fa32c9e9b6945a6833c97f4b499f1f
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f32..736375744 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)