summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-05 08:22:11 +0200
committerAndreas Jaeger <aj@suse.com>2020-04-05 10:46:10 +0200
commit3e7d44746eaac91d684654702f27b156b46df831 (patch)
treec03bf65d8efae954c232e0fe97eab57c68daa15f /setup.py
parent0edb9d9f61ba8734949f49112e93b4b1ca211721 (diff)
downloadironic-python-agent-3e7d44746eaac91d684654702f27b156b46df831.tar.gz
Cleanup py27 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo * Some other sections are obsolete - Update classifiers - Update requirements, no need for python_version anymore - Use sphinx-build Change-Id: I8abd764d97a6711d3e6347ec3a7b8967f1512006
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 566d8443..cd35c3c3 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)