summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHervé Beraud <hberaud@redhat.com>2020-02-03 17:47:44 +0100
committerHervé Beraud <hberaud@redhat.com>2020-02-03 18:35:08 +0100
commit32a1b6e94845b081e9c00d235320b2014cf18d71 (patch)
tree6723c265163df103db1dba7f05481bc3a835476a /setup.py
parent3ad0a72cdddccbb236eceb3ea0f754994af8da1f (diff)
downloadoslo-messaging-32a1b6e94845b081e9c00d235320b2014cf18d71.tar.gz
[ussuri][goal] Drop python 2.7 support and testing11.0.0
OpenStack is dropping the py2.7 support in Ussuri cycle. Complete discussion & schedule can be found in - http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html - https://etherpad.openstack.org/p/drop-python2-support Ussuri Communtiy-wide goal: https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html Change-Id: I15cc79159b603e232e442e202c78d6c56dc73252
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d844..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)