summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHervé Beraud <hberaud@redhat.com>2020-02-03 18:30:47 +0100
committerHervé Beraud <hberaud@redhat.com>2020-02-03 18:30:47 +0100
commit18685083414cc247bb96f656a65e6b8c7f989ce0 (patch)
tree2dc8a57f1e6df3d1dcb47a0cb835bf4d9adc2183 /setup.py
parent8317c3e9d2ab948382a64abead25b079aff1f72e (diff)
downloadoslo-utils-18685083414cc247bb96f656a65e6b8c7f989ce0.tar.gz
[ussuri][goal] Drop python 2.7 support and testing4.0.0
OpenStack is dropping the py2.7 support in Ussuri cycle. Complete discussion & schedule can be found in - http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html - https://etherpad.openstack.org/p/drop-python2-support Ussuri Communtiy-wide goal: https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html Change-Id: If437786eb8dbba9386dd473b45dab0933812c649
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d844..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)