summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDouglas Mendizabal <douglas.mendizabal@rackspace.com>2013-09-02 18:13:17 -0500
committerDouglas Mendizabal <douglas.mendizabal@rackspace.com>2013-09-02 18:13:17 -0500
commit0c132168604633a1ab1eaf4981a5a163afcebaca (patch)
tree9032ab001524a6b181c2f5b181036d89ddd98c11 /setup.py
parent3c9f3cdf52c19fc23af59bb6366fcc56bcc0cfe1 (diff)
downloadpython-barbicanclient-0c132168604633a1ab1eaf4981a5a163afcebaca.tar.gz
Clean up imports and update requirements
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 86b4fd6..96584ec 100644
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,7 @@
import os
import setuptools
+
name = 'python-barbicanclient'
@@ -46,15 +47,16 @@ setuptools.setup(
keywords="openstack encryption key-management secret",
url='https://github.com/cloudkeep/barbican',
license='Apache License (2.0)',
- author='OpenStack, LLC.',
- author_email='openstack-admins@lists.launchpad.net',
- packages=setuptools.find_packages(exclude=['tests', 'tests.*', 'examples', 'examples.*']),
+ author='Rackspace, Inc.',
+ author_email='openstack-dev@lists.openstack.org',
+ packages=setuptools.find_packages(
+ exclude=['tests', 'tests.*', 'examples', 'examples.*']
+ ),
install_requires=[
- 'eventlet>=0.12.1',
- 'httplib2>=0.7.7',
'argparse>=1.2.1',
- 'python-keystoneclient>=0.2.3',
- 'iso8601>=0.1.4'
+ 'eventlet>=0.13.0',
+ 'requests>=1.2.3',
+ 'python-keystoneclient>=0.3.2',
],
test_suite='nose.collector',
tests_require=['nose'],