diff options
author | OpenStack Proposal Bot <openstack-infra@lists.openstack.org> | 2014-05-30 16:32:34 +0000 |
---|---|---|
committer | OpenStack Proposal Bot <openstack-infra@lists.openstack.org> | 2014-05-30 16:32:34 +0000 |
commit | 1f7a95fc1586b8e6849caa989084e94d0244ac05 (patch) | |
tree | d079b9f0144f0b31de00668035dc6b83785c97a2 /setup.py | |
parent | 12347c1a474fe2f93edf1c02f6c2c8dc094862b2 (diff) | |
download | python-cinderclient-1f7a95fc1586b8e6849caa989084e94d0244ac05.tar.gz |
Updated from global requirements
Change-Id: I65149149fd5b80e93961206f1c9e2037db764b84
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -17,6 +17,14 @@ # THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT import setuptools +# In python < 2.7.4, a lazy loading of package `pbr` will break +# setuptools if some other modules registered functions in `atexit`. +# solution from: http://bugs.python.org/issue15881#msg170215 +try: + import multiprocessing # noqa +except ImportError: + pass + setuptools.setup( setup_requires=['pbr'], pbr=True) |