summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-06-02 08:40:12 -0400
committerJenkins <jenkins@review.openstack.org>2013-06-25 19:04:30 +0000
commit5cc8a47d403fe40417672e930de0808a21cd9189 (patch)
tree375a1138649cc8991d4e0e1c05dc8bb10ede74c1 /setup.py
parent6bef8ef87a44d1252864461ecbabc81aa6e76575 (diff)
downloadzuul-5cc8a47d403fe40417672e930de0808a21cd9189.tar.gz
Migrate to pbr.
Change-Id: I734f0f8237fb603ee41a39f06e63c007e79825a9 Reviewed-on: https://review.openstack.org/33350 Reviewed-by: James E. Blair <corvus@inaugust.com> Reviewed-by: Doug Hellmann <doug.hellmann@dreamhost.com> Approved: James E. Blair <corvus@inaugust.com> Tested-by: Jenkins
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py54
1 files changed, 12 insertions, 42 deletions
diff --git a/setup.py b/setup.py
index c0a250c79..59a00909e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,51 +1,21 @@
#!/usr/bin/env python
-# Copyright 2012 Hewlett-Packard Development Company, L.P.
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
-# Licensed under the Apache License, Version 2.0 (the "License"); you may
-# not use this file except in compliance with the License. You may obtain
-# a copy of the License at
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-# License for the specific language governing permissions and limitations
-# under the License.
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import setuptools
-from zuul.openstack.common import setup
-
-requires = setup.parse_requirements()
-test_requires = setup.parse_requirements(['tools/test-requires'])
-depend_links = setup.parse_dependency_links()
-project = 'zuul'
setuptools.setup(
- name=project,
- version=setup.get_version(project),
- author='Hewlett-Packard Development Company, L.P.',
- author_email='openstack@lists.launchpad.net',
- description='Trunk gating system',
- license='Apache License, Version 2.0',
- url='http://launchpad.net/zuul',
- packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
- include_package_data=True,
- cmdclass=setup.get_cmdclass(),
- install_requires=requires,
- dependency_links=depend_links,
- zip_safe=False,
- classifiers=[
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Information Technology',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python'
- ],
- entry_points={
- 'console_scripts': [
- 'zuul-server=zuul.cmd.server:main',
- ],
- }
-)
+ setup_requires=['d2to1', 'pbr'],
+ d2to1=True)