summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames E. Blair <jeblair@hp.com>2012-05-29 14:49:32 -0700
committerJames E. Blair <jeblair@hp.com>2012-05-29 14:49:32 -0700
commitee743613ce5b3aee11d12e91e932d7876bc0b40c (patch)
tree971b887d507039caa5ff68d4c4ef238b2b1cc225 /setup.py
downloadzuul-ee743613ce5b3aee11d12e91e932d7876bc0b40c.tar.gz
Initial commit.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000..8456cc4bb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,31 @@
+#!/usr/bin/env python
+# Copyright 2012 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may
+# not use this file except in compliance with the License. You may obtain
+# a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations
+# under the License.
+
+from setuptools import find_packages
+from setuptools.command.sdist import sdist
+from setuptools import setup
+import subprocess
+
+setup(name='zuul',
+ version='1.0',
+ description="Trunk gating system",
+ license='Apache License (2.0)',
+ author='Hewlett-Packard Development Company, L.P.',
+ author_email='openstack@lists.launchpad.net',
+ url='http://launchpad.net/zuul',
+ scripts=['zuul-server'],
+ include_package_data=True,
+ zip_safe=False,
+ )