summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2015-06-22 15:42:29 -0700
committerBen Pfaff <blp@nicira.com>2015-06-24 16:55:48 -0700
commit99635791adde88469a2a472af009eb7fa6117c60 (patch)
treec585ad18d6fd8237efaa61227f4d459c86e36364 /Makefile.am
parentd5651b84e7b0e2beb6e35bd16bb29a45963e21e2 (diff)
downloadopenvswitch-99635791adde88469a2a472af009eb7fa6117c60.tar.gz
Makefiles: Move xml2nroff rule from ovn directory to top level.
Originally only the OVN documentation used the XML format, but now it's used outside the ovn directory (initially for ovs-sim.1) so it's more logical to have the xml->nroff rule at the top level. Reported-by: Alex Wang <alexw@nicira.com> Signed-off-by: Ben Pfaff <blp@nicira.com> Acked-by: Alex Wang <alexw@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 182bb69a1..a659814cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -177,6 +177,24 @@ SUFFIXES += .in
fi
$(AM_V_at) mv $@.tmp $@
+SUFFIXES += .xml
+%: %.xml
+ $(AM_V_GEN)$(run_python) $(srcdir)/build-aux/xml2nroff $< > $@.tmp \
+ --version=$(VERSION) \
+ PKIDIR='$(PKIDIR)' \
+ LOGDIR='$(LOGDIR)' \
+ DBDIR='$(DBDIR)' \
+ PERL='$(PERL)' \
+ PYTHON='$(PYTHON)' \
+ RUNDIR='$(RUNDIR)' \
+ VERSION='$(VERSION)' \
+ localstatedir='$(localstatedir)' \
+ pkgdatadir='$(pkgdatadir)' \
+ sysconfdir='$(sysconfdir)' \
+ bindir='$(bindir)' \
+ sbindir='$(sbindir)'
+ $(AM_v_at)mv $@.tmp $@
+
.PHONY: clean-pycov
clean-pycov:
cd $(srcdir) && rm -f $(PYCOV_CLEAN_FILES)