summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2012-06-07 10:02:53 +0100
committerSimon Kelley <simon@thekelleys.org.uk>2012-06-07 10:02:53 +0100
commit43c271b07c0332a08ff38e32ae53b431a8988dcd (patch)
tree8a497a857d17d857160365b0d538e9ba78a800d7 /debian
parent24ce681e5154e10b347bfaa3570c4446b9682784 (diff)
downloaddnsmasq-43c271b07c0332a08ff38e32ae53b431a8988dcd.tar.gz
Debian package build - pass calculated LDFLAGS to make.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 783833f..b1737b0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dnsmasq (2.62-2) unstable; urgency=low
+
+ * Pass LDFLAGS to make to get hardening in linker.
+
+ -- Simon Kelley <simon@thekelleys.org.uk> Thu, 7 June 2012 09:53:43 +0000
+
dnsmasq (2.62-1) unstable; urgency=low
* New upstream.
diff --git a/debian/rules b/debian/rules
index e49e8fe..762b089 100755
--- a/debian/rules
+++ b/debian/rules
@@ -115,7 +115,7 @@ binary-arch: checkroot
-d debian/base/usr/share/doc/$(package)/examples \
-d debian/base/var/run \
-d debian/base/var/lib/misc
- make $(TARGET) PREFIX=/usr DESTDIR=`pwd`/debian/base CFLAGS="$(CFLAGS)" COPTS="$(COPTS)" CC=gcc
+ make $(TARGET) PREFIX=/usr DESTDIR=`pwd`/debian/base CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(COPTS)" CC=gcc
ifeq (,$(findstring nodocs,$(DEB_BUILD_OPTIONS)))
install -m 644 doc.html debian/base/usr/share/doc/$(package)/.
install -m 644 setup.html debian/base/usr/share/doc/$(package)/.
@@ -155,7 +155,7 @@ ifeq ($(DEB_BUILD_ARCH_OS),linux)
-d debian/utils/usr/share/man/man1 \
-d debian/utils/usr/bin \
-d debian/utils/usr/share/doc/dnsmasq-utils
- make -C contrib/wrt PREFIX=/usr DESTDIR=`pwd`/debian/utils CFLAGS="$(CFLAGS)" COPTS="$(COPTS)" CC=gcc
+ make -C contrib/wrt PREFIX=/usr DESTDIR=`pwd`/debian/utils CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(COPTS)" CC=gcc
install -m 755 contrib/wrt/dhcp_release debian/utils/usr/bin/dhcp_release
install -m 644 contrib/wrt/dhcp_release.1 debian/utils/usr/share/man/man1/dhcp_release.1
gzip -9 debian/utils/usr/share/man/man1/dhcp_release.1