summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2012-02-10 21:19:25 +0000
committerSimon Kelley <simon@thekelleys.org.uk>2012-02-10 21:19:25 +0000
commit627797800dfbcee65e7f21cacc3573695023d840 (patch)
tree90d93889b34e6a960437a4509c899880e942f05f /debian
parentc6cc03ed0c0647e9c204a183c7c8f56216f52e3d (diff)
downloaddnsmasq-627797800dfbcee65e7f21cacc3573695023d840.tar.gz
Report correct error if prefix in dhcp-range is less than 64
Update debian/rules to provide no_dhcp6 and use_lua build opts. Log DHCPv6 information request packets.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules28
1 files changed, 18 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index b34c346..6416ba9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,7 @@
package=dnsmasq-base
# policy manual, section 10.1
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS = -g -O0 -Wall -W
else
CFLAGS = -g -O2 -Wall -W
@@ -23,43 +23,51 @@ TARGET = install-i18n
DEB_BUILD_ARCH_OS := $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-ifeq (,$(findstring nodbus,$(DEB_BUILD_OPTIONS)))
+ifeq (,$(filter nodbus,$(DEB_BUILD_OPTIONS)))
COPTS += -DHAVE_DBUS
endif
-ifeq (,$(findstring noconntrack,$(DEB_BUILD_OPTIONS)))
+ifeq (,$(filter noconntrack,$(DEB_BUILD_OPTIONS)))
ifeq ($(DEB_BUILD_ARCH_OS),linux)
COPTS += -DHAVE_CONNTRACK
endif
endif
-ifneq (,$(findstring noipv6,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noipv6,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_IPV6
endif
-ifneq (,$(findstring notftp,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter notftp,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_TFTP
endif
-ifneq (,$(findstring nodhcp,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter nodhcp,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_DHCP
endif
-ifneq (,$(findstring noscript,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter nodhcp6,$(DEB_BUILD_OPTIONS)))
+ COPTS += -DNO_DHCP6
+endif
+
+ifneq (,$(filter noscript,$(DEB_BUILD_OPTIONS)))
COPTS += -DNO_SCRIPT
endif
-ifneq (,$(findstring nortc,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter nortc,$(DEB_BUILD_OPTIONS)))
COPTS += -DHAVE_BROKEN_RTC
endif
-ifneq (,$(findstring noi18n,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noi18n,$(DEB_BUILD_OPTIONS)))
TARGET = install
- ifeq (,$(findstring noidn, $(DEB_BUILD_OPTIONS)))
+ ifeq (,$(filter noidn, $(DEB_BUILD_OPTIONS)))
COPTS += -DHAVE_IDN
endif
endif
+ifneq (,$(filter uselua,$(DEB_BUILD_OPTIONS)))
+ COPTS += -DHAVE_LUASCRIPT
+endif
+
clean:
$(checkdir)
rm -rf debian/daemon debian/base debian/utils debian/*~ debian/files debian/substvars debian/utils-substvars